Shockwave Player: Unable to install/update plugin for Mac OS X 10.10 (Yosemite)

Follow

November 2014:
At this time, Adobe has not released a compatible Shockwave Player plugin for Mac OS X 10.10 Yosemite.  In order to resolve this issue in the short term until a compatible Shockwave Player is released by Adobe, the following steps can be taken:

  1. Download the existing Shockwave Player plugin (atttached) and unzip it to your desktop
  2. Open finder, navigate to "/Library/Internet Plug-Ins/"
  3. Copy the plugin file into that folder (this might require administrator privileges)
  4. Restart your computer
  5. Shockwave player should now be available for installed browsers.”